package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)BEGIN(.*999.*?)END`)
var str = `BEGIN11119991112AADFSFENDBEGINASSD12UHYEND`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}