$re = '/BEGIN(.*999.*?)END/m';
$str = 'BEGIN11119991112AADFSFENDBEGINASSD12UHYEND';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);