#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![^"'\n]*["']).*?(?:\b\d+|<<.*?>>)\s*\/\s*0+\b"
Local $sString = "1) <<Employee Profile/Employee Data/Employee/Age>> / 1 * <<age>> / 00 + <<gender>> / 001" & @CRLF & _
"2) <<Employee Profile/Employee Data/Employee/Age>>/0" & @CRLF & _
"3) 1 / 0000 + 1 / 00" & @CRLF & _
"4) 1/0" & @CRLF & _
"" & @CRLF & _
"3) 1 / 0000 + 1 / 01" & @CRLF & _
"" & @CRLF & _
"3) 1 / 0000 + 1 "/ 01" & @CRLF & _
"4) 1/0"" & @CRLF & _
"3) 1 / 0900 + 1 / 99"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")