import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![^\"'\\n]*[\"']).*?(?:\\b\\d+|<<.*?>>)\\s*\\/\\s*0+\\b";
final String string = "1) <<Employee Profile/Employee Data/Employee/Age>> / 1 * <<age>> / 00 + <<gender>> / 001\n"
+ "2) <<Employee Profile/Employee Data/Employee/Age>>/0\n"
+ "3) 1 / 0000 + 1 / 00\n"
+ "4) 1/0\n\n"
+ "3) 1 / 0000 + 1 / 01\n\n"
+ "3) 1 / 0000 + 1 \"/ 01\n"
+ "4) 1/0\"\n"
+ "3) 1 / 0900 + 1 / 99";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}