import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<!--(?:(?!<!).)+?stylesheet.+?-->";
final String string = "<!-- The quick brown fox \n"
+ " jumps over the lazy dog -->\n\n"
+ "<!--[if IE 7]>\n"
+ " <link rel=\"stylesheet\" type=\"text/css\" href=\"/supersheet.css\" />\n"
+ "<![endif]-->\n\n"
+ "<!-- Pack my box with five dozen liquor jugs -->";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}