import re
regex = re.compile(r"<!--(?:(?!<!).)+?stylesheet.+?-->", flags=re.DOTALL)
test_str = ("<!-- The quick brown fox \n"
" jumps over the lazy dog -->\n\n"
"<!--[if IE 7]>\n"
" <link rel=\"stylesheet\" type=\"text/css\" href=\"/supersheet.css\" />\n"
"<![endif]-->\n\n"
"<!-- Pack my box with five dozen liquor jugs -->")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")