import re
regex = re.compile(r"night (.*)|Total(.*)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("<strong class=\"price scarcity_color sr_gs_rackrate_price\n"
" anim_rack_rate \n"
"\" title=\"Price for 1 night £69\">\n"
"<b>\n"
"<span class=\"sr_gs_rackrate_total\">Total: </span>\n"
"£69\n"
"</b>\n"
"</strong>\n"
"<td class=\"totalPrice\" colspan=\"3\">\n"
"<div data-component=\"track\" data-hash=\"OLNYSRfCbdWGffSRe\" data-stage=\"1\" data-track=\"view\"></div>\n"
"Total: £145\n"
"</td>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")