const regex = /(\w+)=(?:"([^"]*)"|(\S*))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)=(?:"([^"]*)"|(\\S*))', 'g')
const str = `t=2016-08-03T18:47:26+0000 lvl=dbug msg="Event Recieved" Service=SomeService`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}