$re = '/(\w+)=(?:"([^"]*)"|(\S*))/';
$str = 't=2016-08-03T18:47:26+0000 lvl=dbug msg="Event Recieved" Service=SomeService';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);