package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+(?:-\d+)? ((?:.)+) `)
var str = `23 Barrel Rd.
14 Old Mill Dr.
65-345 Howard's Bluff`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}