$re = '/\d+(?:-\d+)? ((?:.)+) /m';
$str = '23 Barrel Rd.
14 Old Mill Dr.
65-345 Howard\'s Bluff';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);