package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-z]{1,8})s`)
var str = `wahbdwgubsuregbbu`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}