const regex = /([A-z]{1,8})s/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-z]{1,8})s', '')
const str = `wahbdwgubsuregbbu`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}