package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(@\w+)`)
var str = `RT@user1: This is a retweet that mentions @user2.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}