$re = '/(@\w+)/';
$str = 'RT@user1: This is a retweet that mentions @user2.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);