import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(\\G|<p class=\"oyric\">)((?!</p>).)*?\\K((?<=>)\\h+|\\h+(?=<|\\h))";
final String string = " <div align=\"justify\">\n"
+ " <table width=\"552\" border=\"0\">\n"
+ " <tr>\n"
+ " <td><h1 class=\"article\" itemprop=\"name\">Modals</h1></td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td class=\"text_dreapta\">On February 25, 2011, in <a href=\"modals.html\" title=\"View all articles from Modals\" class=\"external\" rel=\"category tag\">Destiny</a>, by Roland Worrior</td>\n"
+ " </tr>\n"
+ " </table>\n"
+ " <p class=\"text_obisnuit2\"><em>Should I stay or should I go?</em></p>\n"
+ " <p class=\"oyric\"> Laurie Strode comes to her final confrontation with Michael Myers, the masked figure who has haunted her since she narrowly escaped. </p>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}