const regex = /(?=(.{5}))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(.{5}))', 'gm')
const str = `butterfly`;
const subst = `$1|`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);