use strict;
my $str = 'butterfly';
my $regex = qr/(?=(.{5}))/mp;
my $subst = '$1|';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";