package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:03[0-9]{9}(?:,|$))+$`)
var str = `matches 03123465789,03335678990,03453465789
doesn't match 03123465789,03335678990,03453465789 some text
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}