$re = '/(?:03[0-9]{9}(?:,|$))+$/m';
$str = 'matches 03123465789,03335678990,03453465789
doesn\'t match 03123465789,03335678990,03453465789 some text
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);