package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^20[d]{10}$`)
var str = `20522621263`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}