$re = '/^20[d]{10}$/';
$str = '20522621263';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);