const regex = /^(?=^(?:(\d\d(?:[02468][048]|[13579][26]))-02-29|\d{4}-(?:0[13578]|1[02])-31|\d{4}-(?:0[13-9]|1[0-2])-30|\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|1\d|2[0-8])))(\d{4})-(\d\d?)-(\d\d?)(?:\x20(\d{2}):(\d{2})(?::(\d{2})(.\d+)?)?)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=^(?:(\\d\\d(?:[02468][048]|[13579][26]))-02-29|\\d{4}-(?:0[13578]|1[02])-31|\\d{4}-(?:0[13-9]|1[0-2])-30|\\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|1\\d|2[0-8])))(\\d{4})-(\\d\\d?)-(\\d\\d?)(?:\\x20(\\d{2}):(\\d{2})(?::(\\d{2})(.\\d+)?)?)?$', 'gm')
const str = `This captures the year, month and day of a date at the 2nd, 3rd and 4th groups.
Also captures leap years in day 29 of February in 1st capturing group.
2014-05-31
2016-02-29
2004-08-10 13:02
2002-02-08 19:35:00
1999-12-31 23:59:59.999
1996-02-29 23:59:59.9999
Regex used: ^(?=^(?:(\\d\\d(?:[02468][048]|[13579][26]))-02-29|\\d{4}-(?:0[13578]|1[02])-31|\\d{4}-(?:0[13-9]|1[0-2])-30|\\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|1\\d|2[0-8]))\$)(\\d{4})-(\\d\\d?)-(\\d\\d?)\$`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}