$re = '/^(?!\.)(?!.*\.$)(?!.*?\.\.)([a-zA-Z0-9.!#$%&\'*+\/=?^_`{|}~-]+)@((?!\.)(?!.*\.$)[a-zA-Z0-9._-]+.[a-zA-Z]{2,6})$/m';
$str = 'pete@openanswers.co.uk
pete.Davies@openanswers.co.uk
pete.Da!#$%&\'*+vies@openanswers.co.uk
pete.Davies.@openanswers.co.uk
pete.Davies@openanswers.co.uk.
pete.Davies@openanswers.co..uk
pete..Davies@openanswers.co.uk
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;