re = /^(?!\.)(?!.*\.$)(?!.*?\.\.)([a-zA-Z0-9.!#$%&'*+\/=?^_`{|}~-]+)@((?!\.)(?!.*\.$)[a-zA-Z0-9._-]+.[a-zA-Z]{2,6})$/m
str = 'pete@openanswers.co.uk
pete.Davies@openanswers.co.uk
pete.Da!#$%&\'*+vies@openanswers.co.uk
pete.Davies.@openanswers.co.uk
pete.Davies@openanswers.co.uk.
pete.Davies@openanswers.co..uk
pete..Davies@openanswers.co.uk
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result