import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(!?.*\\.(docx|pptx|xlsx|pdf|txt|zip))$";
final String string = "C:\\Temp\\file.docx\n"
+ "C:\\Temp\\file.jpg\n"
+ "D:\\Dir1\\Dir2\\hidden.txt\n"
+ "C:\\Another Dir\\temp\\file.doc\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}