re = /^(!?.*\.(docx|pptx|xlsx|pdf|txt|zip))$/m
str = 'C:\\Temp\\file.docx
C:\\Temp\\file.jpg
D:\\Dir1\\Dir2\\hidden.txt
C:\\Another Dir\\temp\\file.doc
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end