# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.{3})(.{17})(.{17})(.{20})(.{20})(.{10})(.{6})(.{30})(.{8})(.{8})(.{17})(.{3})(.{10})(.{3})(.{10})(.{3})(.{15})(.{15})(.{30})(.{8})(.{17})(.{17})(.{2})(.{1})(.{10})(.{10})(.{10})(.{10})(.{10})(.{15})(.{15})(.{30})(.{30})(.{17})(.{17})(.{35})"
test_str = ("PRS00000001 00000999 F9A40A 992419 0000000001 8111437440 201602152016021500000000000000.00 3333333333 b1234567 SNAB111111GCVB2PO34567 0011111 0055555 DEN4444444444 5555555555 REG1111 REG2222 TRANID1 \n"
"PRS00000001 00000999 F9A40A 992419 0000000001 8111437440 201602152016021500000000000000.00 3333333333 b1234567 SNBB222222222ZZPO34567 0011111 0055555 DEN4444444444 5555555555 REG1111 REG2222 TRANID2 \n"
"PRS00000001 00000999 C7973A 992419 0000000001 8111437440 201602152016021500000000000000.00 3333333333 b1234567 SNCC3WDDDDDD123PO34567 0011111 0055555 DEN4444444444 5555555555 REG1111 REG2222 TRANID3 \n"
"PRS00000001 00000999 C7973A 992419 0000000001 8111437440 201602152016021500000000000000.00 3333333333 b1234567 SNDDDDD4R6F1111PO34567 0011111 0055555 DEN4444444444 5555555555 REG1111 REG2222 TRANID4 ")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.