import Foundation
let pattern = #"(.{3})(.{17})(.{17})(.{20})(.{20})(.{10})(.{6})(.{30})(.{8})(.{8})(.{17})(.{3})(.{10})(.{3})(.{10})(.{3})(.{15})(.{15})(.{30})(.{8})(.{17})(.{17})(.{2})(.{1})(.{10})(.{10})(.{10})(.{10})(.{10})(.{15})(.{15})(.{30})(.{30})(.{17})(.{17})(.{35})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
PRS00000001 00000999 F9A40A 992419 0000000001 8111437440 201602152016021500000000000000.00 3333333333 b1234567 SNAB111111GCVB2PO34567 0011111 0055555 DEN4444444444 5555555555 REG1111 REG2222 TRANID1
PRS00000001 00000999 F9A40A 992419 0000000001 8111437440 201602152016021500000000000000.00 3333333333 b1234567 SNBB222222222ZZPO34567 0011111 0055555 DEN4444444444 5555555555 REG1111 REG2222 TRANID2
PRS00000001 00000999 C7973A 992419 0000000001 8111437440 201602152016021500000000000000.00 3333333333 b1234567 SNCC3WDDDDDD123PO34567 0011111 0055555 DEN4444444444 5555555555 REG1111 REG2222 TRANID3
PRS00000001 00000999 C7973A 992419 0000000001 8111437440 201602152016021500000000000000.00 3333333333 b1234567 SNDDDDD4R6F1111PO34567 0011111 0055555 DEN4444444444 5555555555 REG1111 REG2222 TRANID4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}