package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z]{3}|[Dd]?`)
var str = `1
123
a
abc
A
ABC
d
D
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}