$re = '/^[A-Z]{3}|[Dd]?/m';
$str = '1
123
a
abc
A
ABC
d
D
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);