#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(M[A-Z]{2,})<STOP>"
Local $sString = "res = [" & @CRLF & _
" 'NVAKMFPQRKFT<STOP>TVQTLMRNGTLLERG<STOP>CCEVSP'," & @CRLF & _
"" & @CRLF & _
" 'QKRMDCNASV<STOP>TVTVQTLMQTL<STOP>TNTPKGG<STOP>'," & @CRLF & _
"" & @CRLF & _
" 'MEKGYADAE<STOP>RKTF<STOP>MTVRAGCCGI<STOP>MK'" & @CRLF & _
"]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")