$re = '/(M[A-Z]{2,})<STOP>/m';
$str = 'res = [
\'NVAKMFPQRKFT<STOP>TVQTLMRNGTLLERG<STOP>CCEVSP\',
\'QKRMDCNASV<STOP>TVTVQTLMQTL<STOP>TNTPKGG<STOP>\',
\'MEKGYADAE<STOP>RKTF<STOP>MTVRAGCCGI<STOP>MK\'
]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);