$re = '/^[a-z]+(?:(?:[_ ]|\[])[a-z]+)+$/m';
$str = 'ag_b_cf_ajk
zva b c de
hh_b opxop a_b
axz_be
axz be
axz_be_j
axz be j
axz[]be j';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);