// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-z]+(?:(?:[_ ]|\[])[a-z]+)+$").unwrap();
let string = "ag_b_cf_ajk
zva b c de
hh_b opxop a_b
axz_be
axz be
axz_be_j
axz be j
axz[]be j";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}