import re
regex = re.compile(r"\(groupid=\s+(?P<groupid>\d+)", flags=re.UNICODE)
test_str = ("seq_read_4k: (groupid= 0 jobs= 1): err= 0: pid= 7396: Wed Sep 2 14:07:25 2015\n"
" read : io= 72013 MB bw= 614510 KB/s iops= 153627 runt= 120001msec \n"
"-- \n"
"seq_read_128k: (groupid= 1 jobs= 1): err= 0: pid= 7463: Wed Sep 2 14:07:25 2015\n"
" read : io= 74277 MB bw= 633821 KB/s iops= 4951 runt= 120001msec \n"
"-- \n"
"rand_read_4k: (groupid= 2 jobs= 1): err= 0: pid= 7480: Wed Sep 2 14:07:25 2015\n"
" read : io= 4102.4 MB bw= 35006 KB/s iops= 8751 runt= 120001msec \n"
"-- \n"
"rand_read_1M: (groupid= 3 jobs= 1): err= 0: pid= 7497: Wed Sep 2 14:07:25 2015\n"
" read : io= 44963 MB bw= 383678 KB/s iops= 374 runt= 120002msec \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")