use strict;
my $str = 'Received: by with SMTP id gx4so163592215ieb.1
for mail-ie0-x247.google.com <myemailaddress@gmail.com>; Mon, 01 Jun mail-ie0-x247.google.com 2015 18:34:50 -0700 (PDT)
max.google.com
Received: from localhost (localhost.localdomain [127.0.0.1])
by mail.server.com (Postfix) with ESMTP id 822B1190A4AF
for <alex@example.com>; Tue, 17 Feb 2015 13:13:54 +0000 (UTC)
Received: from [x.x.x.x] by mail.kampl.com (Cipher TLSv1.2:AES-SHA:128) (MDaemon PRO v15.0.1)
b-app05-06.boldchat.com
ns126a.ba1.enops.net
ms-out.evernote.com
obeml1.aerlingus.com
NHQSDFEXCHUB01.nam.coair.com
ncsmcexchub01.nam.coair.com
o1.em.thetaoofbadass.com';
my $regex = qr/([a-zA-Z0-9-]+\.{1,}[a-zA-Z0-9-]+\.[a-zA-Z0-9-]{2,})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}