// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([a-zA-Z0-9-]+\.{1,}[a-zA-Z0-9-]+\.[a-zA-Z0-9-]{2,})").unwrap();
let string = "Received: by with SMTP id gx4so163592215ieb.1
for mail-ie0-x247.google.com <myemailaddress@gmail.com>; Mon, 01 Jun mail-ie0-x247.google.com 2015 18:34:50 -0700 (PDT)
max.google.com
Received: from localhost (localhost.localdomain [127.0.0.1])
by mail.server.com (Postfix) with ESMTP id 822B1190A4AF
for <alex@example.com>; Tue, 17 Feb 2015 13:13:54 +0000 (UTC)
Received: from [x.x.x.x] by mail.kampl.com (Cipher TLSv1.2:AES-SHA:128) (MDaemon PRO v15.0.1)
b-app05-06.boldchat.com
ns126a.ba1.enops.net
ms-out.evernote.com
obeml1.aerlingus.com
NHQSDFEXCHUB01.nam.coair.com
ncsmcexchub01.nam.coair.com
o1.em.thetaoofbadass.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}