# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?: (?:LTD|CORP|LLC|INC))+$//;t' <<< "COMPANY_NAME CORP LTD"