$re = '/(?: (?:LTD|CORP|LLC|INC))+$/';
$str = 'COMPANY_NAME CORP LTD';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;