# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"([^\"]*)\"|(?<=,|^)([^,]*)(?=,|$)"
test_str = "45235g4tgd3453452,89789dsjfhwf897897fsd9sd,123456789-82638273-92DA5F569,2016-06-12 06:10:03,4000,\"{ref_action:'3000',result:'500',pfx:'gb'}\",\"{'1000':5,'34567':10}\",10"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.