re = /"([^"]*)"|(?<=,|^)([^,]*)(?=,|$)/
str = '45235g4tgd3453452,89789dsjfhwf897897fsd9sd,123456789-82638273-92DA5F569,2016-06-12 06:10:03,4000,"{ref_action:\'3000\',result:\'500\',pfx:\'gb\'}","{\'1000\':5,\'34567\':10}",10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end