package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)-[^-]+$`)
var str = `branch:resource-fix-c95e12f`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}