$re = '/-[^-]+$/m';
$str = 'branch:resource-fix-c95e12f';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);