using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*reddit\.com\/?(?!(?:message|comments)\/).*?$";
string input = @"https://www.reddit.com/r/MechanicalKeyboards/comments/7xtvwj/black_like_my_soul/
https://www.reddit.com/message/inbox/
https://www.reddit.com/r/allcomments/asdf
https://www.reddit.com/r/MechanicalKeyboards
https://www.reddit.com/r/MechanicalKeyboards/
https://www.reddit.com/r/hearthstone/?count=25&after=t3_7y194s";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}