import re
regex = re.compile(r"^.*reddit\.com\/?(?!(?:message|comments)\/).*?$", flags=re.MULTILINE)
test_str = ("https://www.reddit.com/r/MechanicalKeyboards/comments/7xtvwj/black_like_my_soul/\n"
"https://www.reddit.com/message/inbox/\n"
"https://www.reddit.com/r/allcomments/asdf\n"
"https://www.reddit.com/r/MechanicalKeyboards\n"
"https://www.reddit.com/r/MechanicalKeyboards/\n"
"https://www.reddit.com/r/hearthstone/?count=25&after=t3_7y194s")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")