import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^";
final String string = "0gXFABYYJ4w\n"
+ "9SbT3q1a6dQ\n"
+ "Px9m5hkr4R0\n"
+ "si65inj9DTQ\n"
+ "Bi5kyehmeaY\n"
+ "RRKBuSYVjcg\n"
+ "Vus1JBAwPz4\n"
+ "J6dl8Gicvv0\n"
+ "9OpVlBDOXYI\n"
+ "MWERAZARYMw\n"
+ "36EBd2Q4-gg\n"
+ "R3nDIZ1XE8Y\n"
+ "nH3a-wwkkkU\n"
+ "WdlyIH2DX60\n"
+ "VTSHzCZ-xss\n"
+ "HBZctpwwPbA\n"
+ "rxbCaiyYSXM\n"
+ "2YHV9ikQ8fM\n"
+ "pm8JXbh-Nc4\n"
+ "GVgfAfj4Eig\n"
+ "TnbSasaBnZ8\n"
+ "jhufM4oeBqE\n"
+ "xEd1WsRKikw\n"
+ "qAHTwM5QvHY\n"
+ "s1ATTIQrmIQ\n"
+ "OnrEnWG99RA\n"
+ "k-AvkeMrybI\n"
+ "scMv18TrCv0\n"
+ "dZ20GnK2qy4\n"
+ "dRX1Qc1BUz8\n"
+ "xWl5NcRB8UI\n"
+ "_DIYqQnJNZE\n"
+ "8jK0yIEUpxg\n"
+ "f81PzYbCkEE\n"
+ "uWqnCCGe4lU\n"
+ "80Uz2iP1FCI\n"
+ "e7I9uSqjxIU\n"
+ "S-EPItXKHn8\n"
+ "CvQY0J4UAPc\n"
+ "h8gkUsjjusU\n"
+ "Pu8myhboOv4\n"
+ "9FMZfTJKmyM\n"
+ "dySPsLzD8AI\n"
+ "DuMDzczLoXY\n"
+ "ZtgLSzoFUMM\n"
+ "72KC8xMmERU\n"
+ "vup1zS44HtM\n"
+ "4k7dEJVFKYM\n"
+ "jS1wmaNVGts\n"
+ "toyaz8OgKlA\n"
+ "zyJP3Cckw24\n"
+ "Ou0evRc1Deg\n"
+ "ttVCIx5xvMQ\n"
+ "tBfWb5IrbOI\n"
+ "l0S05wu6WKk\n"
+ "ZOZD6Oe0Inc\n"
+ "VJit1m74YfQ\n"
+ "pnS1JZcAw68\n"
+ " -IRbsYNBBFQ\n"
+ "68ZFFoToojU\n"
+ "gVHCYIdbLg4\n"
+ "YYZz8BXN7ag\n"
+ "1HSQO4wRiU8\n"
+ "0gOX4W2PNGM\n"
+ "BA5pmLE-fMk\n"
+ "oig3Mqg7rzs\n"
+ "NR23z1sm6JA\n"
+ "Cw8081tNzZA\n"
+ "0lH8_5ORDsM\n"
+ "Uu9wrx3_1A4\n"
+ "Ag9r0BavajU\n"
+ "si9-L-8clOE\n"
+ "hCcQG8EGB5M\n"
+ "snwUE9XkmXg\n"
+ "2_eudldBr9U\n"
+ "vgOTxZtlXys\n"
+ "mmK71ZfaZO4\n"
+ "K5Vm_592_3g\n"
+ "UgLEeINmXBk\n"
+ "PWdM8XJ7ets\n"
+ "f4GL62UTcdQ\n"
+ "CvUhGKhvfrI\n"
+ "46JmTj5JEVI\n"
+ "NPiAK33CfxQ\n"
+ "zgZ52M4a_R0\n"
+ "2l4GAPu36fA\n"
+ "I6UQukiQbnk\n"
+ "p0zIbYCu7Yc\n"
+ "rOjbXSry87w\n"
+ "67vr-3kpX3Q\n"
+ "JocAXINz-YE\n"
+ "B-RyOg1yt48\n"
+ "9tbRaEHFhh8\n"
+ "tfa7lLEMZDA\n"
+ "6glk4oMbgKE\n"
+ "1JTndrLHHt8\n"
+ "PidI5ZVgpx8\n"
+ "5pErjN8l2c4\n"
+ "scogMj8GjOo\n"
+ "QIuIdZ_L4iY\n"
+ "ufWIQbb2-qg\n"
+ "csY_i30TbsM\n"
+ "cV77lUcEvyE\n"
+ "9gpvus-fPyo\n"
+ "zz3U9xMQvOo\n"
+ "6tLjsVu917A\n"
+ " -WUfUald0-U\n"
+ "rm4vsbU7KDo\n"
+ "BnBNJo1Lqrc\n"
+ "Im6SCddgBiA\n"
+ "OgQ2ecwZodU\n"
+ "oKsYe4Lbfao\n"
+ "do47TMppVcw\n"
+ "4L56cDBpGAg\n"
+ "jGh08mM7NZE\n"
+ "uxYmRvULqqc\n"
+ "GlcT6eN7fWk\n"
+ "D27Bf2oQdP8\n"
+ "9-Y4Nb8lvjU\n"
+ "qLdPs7e3sq8\n"
+ "CClxaRJ0zfU\n"
+ "TW8zIUb0Pes\n"
+ "ZBPV27IE6-Q\n"
+ "CSLztmp1pMk\n"
+ "yhYK7Mrp8DM\n"
+ "0ymCdRe2y0c\n"
+ "LYa5q2AjWNQ\n"
+ "m9LQBc_sR9Y\n"
+ " -FQ9i737-Vk\n"
+ "5F2R0FjzRaI\n"
+ "m-BEAKGllM0\n"
+ "q06FRYlAZeg\n"
+ "DddW7_tLOXc\n"
+ "H413p-5LaIY\n"
+ "9p0pqng6xTg\n"
+ "2jpGJHvWNGE\n"
+ "qyLL__QinB0\n"
+ "MSVbHDb35kM\n"
+ "fXLzyVghHDs\n"
+ "HInIGGXhJHs\n"
+ "rOHTCzwsg1s\n"
+ "nwuNWRxd2SA\n"
+ "Kr4EQDVETuA\n"
+ "MXNDVJix94Y\n"
+ "iyGK6S4gCuk\n"
+ "4OdCNJ2pA1M\n"
+ "v_mpRUw_JDk\n"
+ "fHmmS8J0CNI\n"
+ "J7p4bzqLvCw\n"
+ "FR9FAH1wnx8\n"
+ "2f6Kg4l8P6s\n"
+ "NKFWojBa9vw\n"
+ "6-OjwC1pTPE\n"
+ "1xfFVBzceoY\n"
+ "7jTRZF7XoJg\n"
+ "pJi5VwKin_I\n"
+ "Nk-ZGhs8Ntk\n"
+ "8dMuOnST7Yo\n"
+ "OPG9VKXbdFM\n"
+ "9ScC8HAhnBk\n"
+ "1cgPtmLRAsM\n"
+ "gqpdZ34sVAw\n"
+ "UhZbOQYj4oM\n"
+ "5fAy2qbzLlw\n"
+ "6xelOXDPqOU\n"
+ "SpOd2ZkkGzg\n"
+ "69cgop62oZU\n"
+ "DnEOoCWqY9M\n"
+ "6JUGglBsczQ\n"
+ "WKB9bIz5T_M\n"
+ "6LjdJgTSIRo\n"
+ "o08YscncCTc\n"
+ "6yARlD8ES6U\n"
+ "wxi66Wm0XQw\n"
+ "v8nbdnSpQX4\n"
+ "uJPxcv5veNU\n"
+ "ukTKLdpITVU\n"
+ "BdI7r2Fjiys\n"
+ "JR8qHvqBkYo\n"
+ "6_E3VzxtRMc\n"
+ "fM2Z2et00ww\n"
+ "puBNNKp3m7A\n"
+ "0EyeuEmMBl4\n"
+ "6D6eXGRAbHo\n"
+ "Oe456lW5Nek\n"
+ "9R7FEhpqU3s\n"
+ "LtJc2QbM_pQ\n"
+ "Qnwo6NtLe30\n"
+ "g-LJaQKnpug\n"
+ "hAxeU0gtDkY\n"
+ "sQq7vjCt1Mo\n"
+ "CIyWAkFnX3U\n"
+ "GIbyKYv7hKk\n"
+ "AWv0MuSRll4\n"
+ "bMTI_t0CKE0\n"
+ "58SZRooWqqw\n"
+ "oH03ruYF8p0\n"
+ "lxhCRI8OeZw\n"
+ "fQ-hYPUspaI\n"
+ "P-6y9EsTMBk\n"
+ "0z0dZhIIC50\n"
+ "oMzM3PmYP04\n"
+ "WV9axjWCAUY\n"
+ "XmN4pI0oD88\n"
+ "QPXC4WShltM\n"
+ "IX_RjAxYyXA\n"
+ "Mz1vZKKBkK4\n"
+ "u765IT19u7Y\n"
+ "Zxnnuj4Vp_g\n"
+ "L6wWO3qoGQg\n"
+ "-7HMCgJpXjM\n"
+ "1Oe06936C0c\n"
+ " -PU9GA9VLTw\n"
+ "sd-dK8OqtVU\n"
+ "EmU7_cHfmxQ\n"
+ "UeYYwUhwGxc\n"
+ "2kpgKmDgw5Y\n"
+ "UCHLxIN0_ag\n"
+ "FetujvIrAUY\n"
+ "z1_BHJpbcsc\n"
+ "jR7qi2Q1xLc\n"
+ "gvrVXKAUhSQ\n"
+ "dz4e2TfJ86U\n"
+ "vBtvhPM2GHc\n"
+ "ULSKXyITnrg\n"
+ "j5F4tPhtsdA\n"
+ "I0o1rgVsd18\n"
+ "pj4UebFCeoY\n"
+ "jb5R5pe68bo\n"
+ "HnHvacpkG0g\n"
+ "5NFL2uV7kps\n"
+ "1aWflmFDres\n"
+ "LfKvGCFmBuM\n"
+ "MgIBoRIBQD0\n"
+ "lHl9-CcDD1s\n"
+ "bO3XsqJ-xo4\n"
+ "286OjxGt_Yc\n"
+ "3J4F0mWitrA\n"
+ " -rSKujuF0f4\n"
+ "jj-_1kvwO4o\n"
+ "Yl-Z9DOqluc\n"
+ "canQwTAoxIw\n"
+ "s7yvqysENYY\n"
+ "AY7H2sNBVZI\n"
+ "QTa6m_lW2R8\n"
+ "Bf-eRpMS2Q4\n"
+ "GcVKnErkbSQ\n"
+ "Lh-rolwcCGI\n"
+ "eM0l6zfnpO8\n"
+ "dLBrhd1yqN4\n"
+ "VOjh0kgbMMk\n"
+ "Mxar_gA2buw\n"
+ "SDl9a5Vsb_0\n"
+ "7r9roPVhwE8\n"
+ " -tfues1Cdgc\n"
+ "jZA0IdOo6U8\n"
+ "TVHA6o30yBA\n"
+ "bEdz42UN0Uk\n"
+ "GF3xmR7YJ0E\n"
+ "HAOebnPiHS4\n"
+ "zui80NELT14\n"
+ "gJAy42ccp0w\n"
+ "y-W-Gbo0uMY\n"
+ "uyZIC3jSDD0\n"
+ "9VsLNuHU3Bw\n"
+ "VDTKMKo-Cro\n"
+ "Fb3j_yuFh1s\n"
+ "VnVCXegWlLc\n"
+ "cwfzyzuKp5o\n"
+ "0Sx25mlo8wk\n"
+ "Q7nj1gfQiio\n"
+ "DMIj56k484Y\n"
+ "FEuYZENFZbs\n"
+ "HTd3l-_Zkw0\n"
+ "8D9sCWsKlRM\n"
+ "3Uoe8W649pw\n"
+ "y_16OUXA6D8\n"
+ "wXm07jdyT2Y\n"
+ "OHXYPeuR4Zk\n"
+ "1sJhn_3oZdU\n"
+ "xE5k9iMi8K4\n"
+ "TGd2MwWGpXY\n"
+ "PJqou7PFTk0\n"
+ "2fBlfEmgrwI\n"
+ "7BM7fL86vng\n"
+ "_8I4Dki8KC4\n"
+ "DbyjnjgN9Ao\n"
+ "miZ5SQYCqxU\n"
+ "FHAnyIbgIvo\n"
+ "EZxk94ch2Yk\n"
+ "pWI0Hi8q1II\n"
+ "r4A0YC74Zxc\n"
+ "pE0-mVGFIOc\n"
+ "fI8eIOCerZw\n"
+ "_MGo4X68xJA\n"
+ "2uBNeUw9_gI\n"
+ "2hpwXvW7jbk\n"
+ "MELuq9C6X0w\n"
+ "sc-sc9ewn14\n"
+ "mbOATjUKm_k\n"
+ "R9I_BS8l6aE\n"
+ "ipsvXDL-fOo\n"
+ "tcERO0i7W_Q\n"
+ "e-NAfJsHGk8\n"
+ "fAqa1ozCuj8\n"
+ "Gifk8x7ZHVE\n"
+ "rx2NAFpSdik\n"
+ "ZYjdYiLRkwY\n"
+ "4xtwjLqdaj0\n"
+ "H3UIHZshNQ0\n"
+ "drsGou-Ztt8\n"
+ "c0GRgiD_EYM\n"
+ "YhX_Woa3kVA\n"
+ "FHKi7DvRcrk\n"
+ "oixiJSJ7kkU\n"
+ "YqAt8-QiBcI\n"
+ "k77mGsNRfs0\n"
+ "Ct0gHrlttD0\n"
+ "9ndjjAdbWlo\n"
+ "LWN0vQpwcKM\n"
+ "2nR1zrNzgcY\n"
+ "P_X6JCMVMQ8\n"
+ "jdbQYDkNjfk\n"
+ "OWomJZ-rRyw\n"
+ "zP7x-H_KV4k\n"
+ "I4P5RR4jPGg\n"
+ "BZm_U5YVwVY\n"
+ "MBcF8cQWcTs\n"
+ "Gz_HEtzYT1o\n"
+ "Szvnvhr8uvc\n"
+ "iD87Aaw3vBM\n"
+ "OX3ecjN0d74\n"
+ "ZAz3rnLGthg\n"
+ "k4V8E5VOMzQ\n"
+ "mm58yEynJyw\n"
+ "FiqoZyauhdA\n"
+ "BkSSOGNeWTM\n"
+ "1MegNXLMUIg\n"
+ "Kyiy2NvSdFs\n"
+ "RdCepOB4BV8\n"
+ "cZCm_i6YvAk\n"
+ "hI_uipQ64hQ\n"
+ "3OTPs0qSJPc\n"
+ "AhyRTEGuToE\n"
+ "eXrmLd5mer4\n"
+ "fzI2PIZJ0vc\n"
+ "1RiYTzdHSDk\n"
+ "RFAG4-iX7Sc\n"
+ "DEQSiNw829g\n"
+ "qslNFQ2CeZY\n"
+ "CikjiSG8eRM\n"
+ "qhvnEfrYzNI\n"
+ "Xrux8DrMsmE\n"
+ " -LAG4abuCAM\n"
+ "pf3mEgXl-mE\n"
+ "u7HqYLVjZUs\n"
+ "-5qqrMu_AZc\n"
+ "73DYB0n8dvE\n"
+ "bHwpmAuIxAU\n"
+ "jZnAUNgcGE4\n"
+ "2_vBJvf5NXk\n"
+ "3BjGGnrEMZw\n"
+ "9fDHrKyV-r8\n"
+ "qR-jjaCGpOU\n"
+ "hGiAwQgRWfw\n"
+ "uxqogWipnNM\n"
+ "Tr_AcfquqpE\n"
+ "CFkPp0NhK_s\n"
+ "v1aL0W5W6tE\n"
+ "5UtqA0l88X4\n"
+ "oOEwt6KIW_U\n"
+ "m9Fbp02qBcw\n"
+ "5oBC5gjrWpM\n"
+ "PErbSeBCjdY\n"
+ "tXqtQdGo_pU\n"
+ "GWDODnFZDRs\n"
+ "yZwcjEBAdPU\n"
+ "YweS8BjdbF8\n"
+ "VZuU_1cLcOM\n"
+ "w2b7dsrzPCQ\n"
+ "t5FnmChlOhM\n"
+ "dxkohu0iZPk\n"
+ "raZ03s1rzd0\n"
+ "9UqiMCqJi-Y\n"
+ "XqgIkH-CuqI\n"
+ "sN-X_03sp-M\n"
+ "lSVwd0-hK14\n"
+ "lbkuNzshvp8\n"
+ "eSis2i7Gx9g\n"
+ "vNZhzy8D8ak\n"
+ "znKlOTltl3g\n"
+ "b39UUughbuA\n"
+ "VRhCzJPP_5w\n"
+ "x5Cky-cOya0\n"
+ "r3K2buWuVS0\n"
+ " -Xr4xUHDP6U\n"
+ "rpLCx-fkEX0\n"
+ "eYfXk_it8qU\n"
+ "kS_NQ7Y5TE8\n"
+ "hwwns39p0zk\n"
+ "l4523ZQQGI8\n"
+ "YYbUnoNLhIs\n"
+ "_jGCL0CkXow\n"
+ "07CQf35Kt4g\n"
+ "uFcQ-OB7cQc\n"
+ "UJj7EgN8aus\n"
+ "Xxd6OY0IQYU\n"
+ "X2wPS6sE6DU\n"
+ "_eb0lRcLJI8\n"
+ "cbnklGwTFwg\n"
+ "H_WN-xTp7oU\n"
+ "tbulbPsysaM\n"
+ "s3-WyRrBB2k\n"
+ "BeuKg_3CCOc\n"
+ "z084LuYa0JY\n"
+ "fkrYH6Ll984\n"
+ "1NCZdkDzphA\n"
+ "65O3aUt9pDM\n"
+ "YoGK3tyQsMM\n"
+ "iGZKk-Npg20\n"
+ "5xDwo3YQxQE\n"
+ "Gs5WlUzk_Ec\n"
+ "IC5VqwM8pp8\n"
+ "ugD3_yt756w\n"
+ "xd0a5rYkRD8\n"
+ "T6RemEBosZ0\n"
+ "fnY3gXSQofU\n"
+ "1KMsRBd_CVE\n"
+ "URJLtHuwmgk\n"
+ "MqQ9mtY-JmI\n"
+ "qG5XQkU4Yb4\n"
+ "FndvOhMegm0\n"
+ "rCSMJ_n07Ds\n"
+ "XjV3JwwpYSo\n"
+ "cXXWGAq1BXk\n"
+ "xIQpLlYC8xA\n"
+ "czpaYKnxqaM\n"
+ "DSQ_qY-j_50\n"
+ "eSDzbrhcZpg\n"
+ "y8kEiL81_R4\n"
+ " -VqRYD4qPmI\n"
+ "H4RELGc9su8\n"
+ "cyywp0uR0Do\n"
+ "oWsRa6PxMS0\n"
+ "nTxI91twGqE\n"
+ "k1qpgQr8wXk\n"
+ "0DzzzRak5dE\n"
+ "V1yoiDhB9ZI\n"
+ "I1eu3YgJ9ro\n"
+ "R63qeX3cbhU\n"
+ "mGyONBxShYo\n"
+ "_ZRJrAHprBM\n"
+ "rC9gTAef0P4\n"
+ "jVBsM8CM0AE\n"
+ "fW8NQgqYoVQ\n"
+ "FLx99uSYDk0\n"
+ "bAu7g4Hoxlg\n"
+ " -T5jjfZtP5g\n"
+ "MxEjnYdfLXU\n"
+ "mEjkui-Cd_E\n"
+ "BDGFLPZvGHI\n"
+ "VxGEUNm_A5k\n"
+ "AFQnRwMDo1I\n"
+ "LBQWAbYihck\n"
+ "0CxacijBc8s\n"
+ "qlP7_oriLvM\n"
+ "jF1dHUUYlbs\n"
+ "MWXzYBrUvMU\n"
+ "fTri9q7YW74\n"
+ "SYJ6OxyHnsY\n"
+ "fLMB6-AHTXI\n"
+ "_VXUiAJi5KY\n"
+ "HKvw-jx3ma0\n"
+ "bm5vtVwF5vk\n"
+ "KtOjdLW3buI\n"
+ "ZJO6sdr9SOI\n"
+ "Keg31bCrXYg\n"
+ "SyLi8yjIHP4\n"
+ "5i5r1wkqTHM\n"
+ "eEYO0rKL6vk\n"
+ " -_JMfiRkdqU\n"
+ "lWg6AKVS0Zo\n"
+ "yUu4SikxUis\n"
+ "q7V-C_fwZKg\n"
+ "fPMsBHWoBsU\n"
+ "RSxB8mPq9t0\n"
+ " -xZol2WbqrU\n"
+ "IUfRBnzWUw0\n"
+ "v_MZfpnCAYo\n"
+ "iP0tHmoc1rs\n"
+ "PWVNzYMyLTY\n"
+ "Cj9fh-2ORDg\n"
+ "57aB8mkPO4g\n"
+ "3nlUDyAVFQk\n"
+ "3d17kzryqqM\n"
+ "Lk7tMF5pTSw\n"
+ "aaRU-4uksg0\n"
+ "qAZQFgnuwGo\n"
+ "MCXQzX5H7SE\n"
+ "7sRgsaA9H0M\n"
+ "zA7qnI7iId4\n"
+ "1YFNOrvUHRg\n"
+ "Ml9TSNW5Ey4\n"
+ "UQNebFZnEQQ\n"
+ "Vy0fFC4CIjI\n"
+ "04o00DJ3Y5w\n"
+ "YeS3PDfUeqM\n"
+ "P3VFJ4jgswY\n"
+ "BZAeyc0T_IY\n"
+ "k5jZP7NY0Ro\n"
+ " -IutkjlQW60\n"
+ "lBgeanW5Qhg\n"
+ "Dg9ew2-VGJQ\n"
+ "mRYSZQqvuus\n"
+ "hu31Gv68_qg\n"
+ "V8Fe6x0fUtU\n"
+ "g0NVaX8DRN4\n"
+ "0XqPpZeW2BY\n"
+ "S5NbBMbPhMw\n"
+ "MfnWQiScDIk\n"
+ "UheJQ_NDKic\n"
+ "U3FV1lBhpA8\n"
+ "UQQpYNc9ibg\n"
+ "tE4MDJHJtVU\n"
+ "fhSTzRnByxs\n"
+ "yAMxx2PSw2A\n"
+ "B56iftyjS3U\n"
+ "P6qoTPhhv9w\n"
+ "cUWLGSPXPRs\n"
+ "bvNr5-CXV60\n"
+ "fBk_Aawlbsg\n"
+ "h19zt9JHDm4\n"
+ "uCIsOh1bggE\n"
+ "BLU_zf3fpNM\n"
+ "w1ScwAjAYow\n"
+ "LwaIy4gP6hA\n"
+ "eHxVq-8RhKg\n"
+ "32pInRftwCo\n"
+ "1QzJi58c1Xw\n"
+ "tnVAEAo7nvA\n"
+ "Q0FdXIYxLbE\n"
+ "cGc6T8X_vZk\n"
+ "Q8_ibpJIvGw\n"
+ "GPoeyB3LK8o\n"
+ "Ct32AqbvS_Y\n"
+ "cC0cVqlb6SE\n"
+ "GkHaAnbpAfw\n"
+ "Rr1Cdli5nE8\n"
+ "jofDfEI2m_o\n"
+ "c9_sYDn0JTA\n"
+ "MwjEV-LtdMM\n"
+ "19zExVchWNw\n"
+ "1qDqPYvPWIo\n"
+ "qpmbfSvtWeI\n"
+ "nj3UwgSE-X0\n"
+ "iG9QNTfGVBM\n"
+ "krZfvUPIVoQ\n"
+ "JPivtCA59fE\n"
+ "KTzYsyS5S88\n"
+ "Nfs9PyTnSu4\n"
+ "gTUoQpDqcWY\n"
+ "qZq56xfSqLc\n"
+ "aOGDdq6Jw2E\n"
+ "7eAG6BB7vUU\n"
+ "BtI7uZMfeZI\n"
+ "uhM1TuhmKoI\n"
+ "Kg5p-mSUO6s\n"
+ "9bXgolwlaWE\n"
+ "GY2tNKSVHzI\n"
+ "GUjyH7tThcE\n"
+ " -yb4WxgNqTA\n"
+ "E3F4qkfQeFY\n"
+ "ZRhE_dgnY7k\n"
+ "ha0jtsdIP24\n"
+ "pV2NTIbTw2Y\n"
+ "_KwItIiO8aQ\n"
+ "7e-0ZWqMtWg\n"
+ "53jx17KvusI\n"
+ "DGybYzBVXL0\n"
+ "Byzhrg7oW58\n"
+ "iV93hXBZinw\n"
+ "VlD6Iku3jzI\n"
+ "zYvAaYkhETY\n"
+ "yx3cw_i3IK4\n"
+ "AWEjFX3yO-4\n"
+ "zhil91dFxQ4\n"
+ "fBVAXhbVwhc\n"
+ "e4GT-FH3jZQ\n"
+ "olf4IO9Dx4E\n"
+ "PUUDWVhxZ4I\n"
+ "AfPVYeVTMS4\n"
+ "2mkE8PYK6Ls\n"
+ "o7KGsgvjZrM\n"
+ "J_tchksaJCM\n"
+ "JNjfoxgegrU\n"
+ "5xlLt4k1lXA\n"
+ "TTf5aWtyEa4\n"
+ "UvdL2eTdXAU\n"
+ "iSMp-sgL5y8\n"
+ "1N93huLYH9g\n"
+ "m6EgJFlT7eA\n"
+ "nHz5expH6BQ\n"
+ "0zcKiBCQ5dY\n"
+ "dr8kFKEowh0\n"
+ "UOLEEkYO4MA\n"
+ "FEIBQt51pu8\n"
+ "eTMRvWNfAd0\n"
+ "DV7biH2ZNj4\n"
+ "w1GBTgxIvcY\n"
+ "g2gRpFLEZJg\n"
+ "9wHeei2PGcs\n"
+ "GGwUL-LAYJo\n"
+ "BMgQ2kMr1I4\n"
+ "HGhLOOz_lyI\n"
+ "Ojg3GoZs4kg\n"
+ "-3vePS_m1hg\n"
+ "fvUfA20fyZQ\n"
+ "VfyewZElFG8\n"
+ "sApmCzCOWAE\n"
+ "83Subiavtxc\n"
+ "pmQ5Xpw95Jc\n"
+ "zf2k9_Nnm7w\n"
+ "1mJa0KyukzU\n"
+ "w3eE3vwXUYE\n"
+ "teZMWgfeyk8\n"
+ "54z605hXwFI\n"
+ "Pf7XsWXrRA0\n"
+ "JBsBG-yIFZI\n"
+ "7QYq1r5gQD4\n"
+ "q1akFrXlIEo\n"
+ "wu5iTLf7miY\n"
+ "45DocMnUVbw\n"
+ "U9ulY90Wy8Y\n"
+ "wp8duWcB_SE\n"
+ "4NDSOSDfDAo\n"
+ "trozv3g7dEc\n"
+ "HWDn8Lzz6_I\n"
+ "jX4wKVIC4Wk\n"
+ "fhCkGKiP95I\n"
+ "mLlwp1aB8Eo\n"
+ "nj71ZP4lG2o\n"
+ "H3wUhwhPXO8\n"
+ "Ba2GJF8ZNIE\n"
+ "UHnjSTQtdFI\n"
+ "YNHBAX1AqBk\n"
+ "7YHlKmkRsDQ\n"
+ "uevXz_O_uOI\n"
+ "6ylTbWMxO7s\n"
+ "8hRk8B6foOE\n"
+ "622RDV68iyk\n"
+ "GK3ByfKfw_w\n"
+ "4ZX2dn2tujM\n"
+ "h83Kk4fVsjA\n"
+ "80a2ptPoVjE\n"
+ "HgqLVUhT0k0\n"
+ "Wf02V8AtMag\n"
+ "5L7gJWjllAY\n"
+ "73nBXvDZ1f4\n"
+ "P74RFL4FgaM\n"
+ "l6RkJVaB43w\n"
+ "8HBcV0MtAQg\n"
+ "JNYRmQGIB4M\n"
+ "TIQv0rR7c_w\n"
+ "thqXwRFuyeI\n"
+ "phLb_SoPBlA\n"
+ "y-5x24V8oSE\n"
+ "I-lGH0gEx7U\n"
+ "__r_j1wYLq4\n"
+ "kj1v1tVscqE\n"
+ "BabETPqgQsg\n"
+ "ogEUHBUV-bo\n"
+ "hIeDrT5Hbgg\n"
+ "3L5zNKi4W-U\n"
+ "zltSGlEvVQw\n"
+ "HF3CNVxj_Yg\n"
+ "aanb7kPc-uI\n"
+ "iPEXRMcCyho\n"
+ "rMWFRKmBE94\n"
+ "thcbyFqyFHg\n"
+ "rOh-SBaibNY\n"
+ "DRFV4UgSFas\n"
+ "CwaYUzwIM1I\n"
+ "hN8C8Ee8yKY\n"
+ "uU9Fe-WXew4\n"
+ "27rYl-D145A\n"
+ "YkWNyjRixyE\n"
+ "gL8RWNCyrOY\n"
+ "ypClJkPhx8o\n"
+ "OyJYZela1fA\n"
+ "eMztEjtPm4o\n"
+ "WICkl0LzIXU\n"
+ "zykN1Vfcajs\n"
+ "14ij-aEbhdY\n"
+ "PTv7cJjNig8\n"
+ "O_8JQDSIIPE\n"
+ "d0fyCiWKHEo\n"
+ "Sd8A3tZboFQ\n"
+ "xjCK7yGDzPs\n"
+ "9k2UIZpi56c\n"
+ "ss5msvokUkY\n"
+ "PhY0XDGGRks\n"
+ "yfcoeKzvNq8\n"
+ "fFpw1t45DXY\n"
+ "Jy1D6caG8nU\n"
+ "9unMOCRfut8\n"
+ "03ue9Nii41g\n"
+ "LNyA9DsKu0s\n"
+ "7HKx1Dj2_VU\n"
+ "WvCFCFqF68U\n"
+ "COz9lDCFHjw\n"
+ "EgfsXTOn_pI\n"
+ "u8Ub6triQPE\n"
+ "2fhA2WM1FpY\n"
+ "tdA8_DtQrlY\n"
+ "1Yn-MEynWC4\n"
+ "N2C9wLqAiPA\n"
+ "rdqlOcYKm_U\n"
+ "bW3ruxYuYVM\n"
+ "C99l5qMtTKA\n"
+ "e54Z65t_5z4\n"
+ " -jH56MgDU-0\n"
+ "b78eGNOAaC0\n"
+ "0Wguzcm-b40\n"
+ "L8h_cx5Z9w0\n"
+ "pZp2lMCRtvU\n"
+ " -y-0hf8bP-0\n"
+ "XpwI3ArofoI\n"
+ "zmauoumuQ4U\n"
+ "KCsex2tGXrs\n"
+ "Z9OEDZ6y6ls\n"
+ "LE3YSfY_64w\n"
+ "DbQ6v5UvMkU\n"
+ "khZ9X6l5AdQ\n"
+ "3ZanKCDvCUo\n"
+ "CuMkHGU6Q-c\n"
+ "oYLHXItjzG4\n"
+ "5hfeDEi8pFA\n"
+ "4R2ph9n1b-g\n"
+ "pAZfrUldiOc\n"
+ "rvjFKme0tt4\n"
+ "BZdD326cUj8\n"
+ "pR-zzUERFas\n"
+ "wdU6tyjEYrY\n"
+ "J87pJrxvJ5E\n"
+ "OQG-NqgKtUs\n"
+ "VSSX2qxAB5g\n"
+ "1MX3GEL2PsU\n"
+ "nnCxT-jf6Tw\n"
+ "QVyBvKsZI3M\n"
+ "LPmUHNaqKP0\n"
+ "2hTwFuLrMZg\n"
+ "MT4Ug_4RqJU\n"
+ "4YMNSvL0Mow\n"
+ "YwEGB_TM3dE\n"
+ "fYxEva04rGE\n"
+ "Fy8f_ZUKvC8\n"
+ "RLqo708UjTw\n"
+ "WakaE9NBvns\n"
+ "FwcF6I8qUxU\n"
+ "CkABCEkhfmU\n"
+ "vg4JGLfF33w\n"
+ "uje5c6P444o\n"
+ "_6UZ0iWyHHc\n"
+ "gQtKJbptcns\n"
+ "NKnuQBW4P1I\n"
+ "bAN54M6QMYI\n"
+ "F89mcNvzeqM\n"
+ "uqm5_ijp6QI\n"
+ "OCY9vN4QzqY\n"
+ "SEM6O4VIXi8\n"
+ "FBiYpeMRcOQ\n"
+ "nXgt3m_qJ6c\n"
+ "rGqcIf-RFt4\n"
+ "39OOABdi3oE\n"
+ "egumxoDWXow\n"
+ "guQ_Sy7uAEI\n"
+ "Zr3pwyRX3XU\n"
+ "h_u2YRluqQc\n"
+ "kdEBBLHwqGw\n"
+ "j59e6lDHudI\n"
+ "fyXD9Cq9Qj8\n"
+ "7M37NSU-piE\n"
+ "dwGswFIHN6o\n"
+ "b_-nuiaRFL0\n"
+ "3SNuuEcbYvY\n"
+ "oUqknxyD8k4\n"
+ "NNtv18qGdlc\n"
+ "MBsQD-7pwgQ\n"
+ "slQBccrGZBg\n"
+ "Rr5IcY2YL_w\n"
+ "9A7s3tNwAvw\n"
+ "dSzIGCxZP54\n"
+ "7AoDRvAFklI\n"
+ "VfInRNGvJJg\n"
+ "iEZNqXjBExw\n"
+ "wYwIqV1RK2A\n"
+ "GLzT-aNr2ss\n"
+ "hm41Du3-2pM\n"
+ "gLo1-dimAbw\n"
+ "Y9zEVu2a-xQ\n"
+ "BqORfK69gDY\n"
+ "mI-_tc5PXA4\n"
+ "MXMGAQ8iiu8\n"
+ "7Ljt29kNHAQ\n"
+ "uPa_ZMwPonk\n"
+ "Yj1VHGIwZUI\n"
+ "sr4vIBaumiM\n"
+ "jBSLzRzU8SU\n"
+ "ufCH9uSYsxM\n"
+ "wOtgPhkf6VA\n"
+ "Z9XwwfEJDeQ\n"
+ "HHhWS6wTWzk\n"
+ "YafP9rG7Ews\n"
+ "Ch5iF1X0UNA\n"
+ "XBzK1cXLxD4\n"
+ "ZTKgD2WKgTo\n"
+ "_mrVU110pzg\n"
+ "SBhfuA73dJw\n"
+ "Jk78U4Pm7bM\n"
+ "5gXrbaDHMrM\n"
+ "wP_zox5uwzg\n"
+ "L-7GQa3G1YA\n"
+ "JN1iN_CPzbo\n"
+ "SLjXz9ghUtk\n"
+ "lsaxzy5bv0A\n"
+ "ArxabWpfBm8\n"
+ "WB7LS3p7Tb4\n"
+ "wSTYIyQxfPQ\n"
+ "IAOvfSqw_Rs\n"
+ "pSjG47s7bgI\n"
+ "x7hdPzmoeVQ\n"
+ "w_a5mRbwr-o\n"
+ "8pafSWv6RV0\n"
+ "EzqB-Lwo2Aw\n"
+ "pQaEIMQLCr0\n"
+ "Tj9e5scOx-Q\n"
+ "JFjNWsC9Lfk\n"
+ "yCZmwGptRyQ\n"
+ "75wmW7xjyog\n"
+ "UeeCaNXNaC4\n"
+ "4c_i_JmttKg\n"
+ "jj2qYltyJGE\n"
+ "QMWKAWky4Kk\n"
+ "5HZ7QBnMX34\n"
+ "crDBuh4WZMg\n"
+ "Dw1Cdy2wQgM\n"
+ "rjLY14u2tXw\n"
+ "6FF1p--Zfjw\n"
+ "1bOZuIYA5xI\n"
+ "HmkwjDqRcIg\n"
+ "KugHDeAv9M4\n"
+ "qG70uKyFJuA\n"
+ "yeFJZB78970\n"
+ "vtj419ogV2k\n"
+ "URzOGF_QGls\n"
+ "6jgBcsRCqI8\n"
+ "KeMMvkFr3FQ\n"
+ "GRdCku68J5k\n"
+ "B9DRhRQUfeA\n"
+ "7f73x0gfrDM\n"
+ "GDAp37aHovo\n"
+ "BOvoL8YEIk0\n"
+ "y7lZ7iXv6ow\n"
+ "lfqNO8UCUgE\n"
+ "zavhi73gdPg\n"
+ "ajLECtAY1KY\n"
+ "sjcgg9fSf1o\n"
+ "KavaUJxnNVU\n"
+ "5uKc4C9T5ZQ\n"
+ " -gfE2ZaFKpM\n"
+ "4NSNZrpHjLc\n"
+ "fLMS2ExiKxg\n"
+ "qBTOmET6hyQ\n"
+ "Qeem6ZVr8Ic\n"
+ "KEM94RudPYc\n"
+ "1piPOhJDjsw\n"
+ "426jDsMYrzQ\n"
+ "4LZspVNCVgI\n"
+ "jNd_LxLnIkM\n"
+ "AF53AqylKxM\n"
+ "5NmJPzJNt0o\n"
+ "0XySyze3Al4\n"
+ "L6QHqtEfchI\n"
+ "76YH1VWA3MY\n"
+ "EIlaJ6VdbqM\n"
+ "XYTWokMGgYE\n"
+ "_bs409WyY1s\n"
+ "4Cfnm5d1DS8\n"
+ "Z4kMbMGaCyw\n"
+ "074r1TFfo0M\n"
+ "bVaWBUs0sgs\n"
+ "XNPCQaIQdEA\n"
+ "qHEZ6CsLmUk\n"
+ " -Iuirr3I6-Q\n"
+ "qkQAUprAWns\n"
+ "eJbUQFrXlvw\n"
+ "AFEC4GezaB0\n"
+ "kY9SyuRQ070\n"
+ "dkS_TrQdvpA\n"
+ "MyesO22H8cI\n"
+ "kTJ5rtWadcE\n"
+ "S6jgzL2Cjbc\n"
+ "5rXomP2HgNQ\n"
+ "Lf_xXwulsnk\n"
+ "AT6YDPWaty4\n"
+ "lMuGbTshbs4\n"
+ "4_GS2_YN5AA\n"
+ "pkIoPUxZ_x0\n"
+ " -Q8x82IBvCM\n"
+ "QSPaMxpkEiQ\n"
+ "7HRKlwPhgcY\n"
+ "QTCUKJv_dmc\n"
+ "HvWhzT_pbJU\n"
+ "bX4Hml7aUvU\n"
+ "iDJfP6akZkY\n"
+ "v1VTgCunuSs\n"
+ "dc6lluyZA8A\n"
+ "mjAcjdvVFPI\n"
+ "gnGqlvvsgbg\n"
+ "jxYUkFCmLQE\n"
+ "0O4FidcZwBM\n"
+ "ycBrCfbuOzA\n"
+ "QEv6VwwcvEE\n"
+ "m6ZCnVHTu1w\n"
+ "sEXj4jYtPB0\n"
+ "qvE0MbqycXs\n"
+ "DLokfuBbnao\n"
+ "7O0_8sVzVts\n"
+ "hKjoLnjjp5E\n"
+ "U-oAnxj4DEM\n"
+ "lSKdCKWU53U\n"
+ "PAQzhOLsLPk\n"
+ "W5Sq71VTJ9Q\n"
+ "8PQu-5TPlik\n"
+ "0ISu3iVzL-U\n"
+ "r5MR7_INQwg\n"
+ "cELBX4RUwMQ\n"
+ "3bSGH0xEJSQ\n"
+ "F-8lGKRKVDg\n"
+ "o8XTO0pRvj8\n"
+ "WG2p4ZcgeH8\n"
+ "HHiddAj-Dqc\n"
+ "WmSb9YLDSYs\n"
+ "plh6_BAuZ_c\n"
+ "DIkOKUBlVoY\n"
+ "yeCcPhEdwws\n"
+ "v_R4Qq1OmBs\n"
+ "Hc8-pD4Dzpg\n"
+ "v7F4QlCsCnA\n"
+ "NZCeMVtSGr0\n"
+ "YJWYkSPQNQE\n"
+ "SUIpbBJeweo\n"
+ "y__6jMr1YLQ\n"
+ "vGDHEJMx7zM\n"
+ "SIi63UvlKG8\n"
+ "tJEbiL905OQ\n"
+ "tQAF5W6NS88\n"
+ "seyuHkQsquo\n"
+ "D5A6Dy6pEZE\n"
+ "zWYyycn_yCU\n"
+ "F-OeFm6y384\n"
+ "NSmxdUPEYfs\n"
+ "3YQh2SkrvSc\n"
+ "LJCECrDyOog\n"
+ "K9R_CxeOGFI\n"
+ "m1RX3yrZVh4\n"
+ "lBJyM80KPzA\n"
+ " -G6NM6S4318\n"
+ "AKWj2icAXgY\n"
+ "Y8qtmD_QTYw\n"
+ "NQHFaXaY5TA\n"
+ "kzLGilDDNQo\n"
+ "xxpfm-5kjDA\n"
+ "9XhBv1u7al0\n"
+ "vIBE-ylmqb4\n"
+ "D1627qvYB5Y\n"
+ "Cj9Cb6xV-S0\n"
+ "Rh3bJKkEhk8\n"
+ "Vo04gkyloWM\n"
+ "XGC4QpDIpJc\n"
+ "__M96CwdX9c\n"
+ "6E5mKpdLQlw\n"
+ "48ydDUQ16RE\n"
+ "V8uWlY-0coE\n"
+ "j7AJdbL27J0\n"
+ "inOEtUwSasc\n"
+ "rNYUdeG6q4A\n"
+ "ZKpLn4GPdHY\n"
+ "Dihsu6bwIVw\n"
+ "FYsKN6DpDcY\n"
+ "6AzImKchKsU\n"
+ "Nscm2ngD90w\n"
+ "RUeiEs3nFLM\n"
+ "yf5Y20Ls7WE\n"
+ "KZ6Qs5ipIq4\n"
+ "Pulrsg3FizI\n"
+ "XmZYt-JBTkw\n"
+ "A4YPuj9H0Wk\n"
+ "qy33soZLh3w\n"
+ "cRFHm-EJsE0\n"
+ "5aGTim8PVh8\n"
+ "ZpqrdN6E9-k\n"
+ "QqnNyMXpuwo\n"
+ "O0Id0olaeFw\n"
+ "1AVYFk6hydo\n"
+ "Mb_GmBX5QvI\n"
+ "nbSNF9_b6jc\n"
+ "dr7VcTX_5pc\n"
+ "CvBGyQvBs9c\n"
+ "WYT4gMDHYZw\n"
+ "sI1JdpnKLBk\n"
+ "z7MzeWiqsVg\n"
+ "qD6vx7IQCS0\n"
+ "Y0lAfQc-iHM\n"
+ "Fx7_8G6DQ1I\n"
+ "3cmJvY1g_bQ\n"
+ "M-0TB9JMpdE\n"
+ "l9fN-8NjrvI\n"
+ "kc-eSOUNtbk\n"
+ "bs5hFgVpGME\n"
+ "6nLfSN2u5gg\n"
+ "frYLvC0mM50\n"
+ "ovH9u4HpeFY\n"
+ "9Ut5l3hZRn0\n"
+ "x3gSsfev1UA\n"
+ "anWb6yQejJU\n"
+ "JdaJM4RZppw\n"
+ "2y6zdAbN9o8\n"
+ "M8q5mg-yj0A\n"
+ "fpgSYmjs2YY\n"
+ "VhVZa63iHzM\n\n";
final String subst = "https://youtube.com/watch?v=";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}