package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\d+\.?)+|[^\d]+`)
var str = `1 potato. chips at 3.99`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}