$re = '/(?:\d+\.?)+|[^\d]+/';
$str = '1 potato. chips at 3.99';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);