$re = '/(?is)(<a[^>]+href\s*=\s*([\'"])([^\'"]+)\2[^>]*>).*?<\/a>/m';
$str = '<a href="http://...">some text</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);